Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA:

Modifizierte Kabelfernbedienung für Sony RX100-Stereogespann 10 Mär 2022 21:58 #31

  • cosima
  • cosimas Avatar
  • Offline
  • Senior Boarder
  • Senior Boarder
  • COrrect Stereo IMAges
  • Beiträge: 53
  • Dank erhalten: 49
Das könnte in der Tat weiterhelfen, Danke für die Links, ich schau's mir an!
Gerhard

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Modifizierte Kabelfernbedienung für Sony RX100-Stereogespann 11 Mär 2022 11:52 #32

  • wbloos
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Beiträge: 33
  • Dank erhalten: 26

die von mir verwendeten Kabel sind abgeschirmt - und auch nur so lang, wie notwendig.


Hallo Gerhard,

Was sind fas für Kabel oder hast du dir die Multiport Stecker besorgt un dann geschirmte Kabel verwendet? Wenn ja, wie/wohin hast du die Schirmung verbunden?

Das Verhalten Deiner Fernbedienung ist nicht logisch, kann mir derzeit keinen Reim drauf machen.

Gruß
Werner




 

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Modifizierte Kabelfernbedienung für Sony RX100-Stereogespann 11 Mär 2022 12:52 #33

  • cosima
  • cosimas Avatar
  • Offline
  • Senior Boarder
  • Senior Boarder
  • COrrect Stereo IMAges
  • Beiträge: 53
  • Dank erhalten: 49
Hallo Werner,
Die Kabel sind von buerklin.com: "PVC Steuerleitung Sensocord SlimLine-D T105 8 x 0,05 mm², geschirmt, schwarz"
Ein Photo der Stecker habe ich bereits im Beitrag #27 veröffentlicht.
Schirmung habe ich drei verschiedene Varianten durchprobiert:
a) (nur) an Kamera mit Masse verbunden
b) (nur) an Fernbedienung mit Masse verbunden
c) an keiner Seite mit Masse verbunden
All das ohne Einfluß auf die Funktion.
Einen "zufälligen Fehler" kann ich auch ausschließen, denn ich habe die Fernbedienung zweimal gebaut -
mit identischem Verhalten.
Die Variante "mehrere verschiedene Kameras" durchprobieren verkneife ich mir ;-)
Gerhard

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Modifizierte Kabelfernbedienung für Sony RX100-Stereogespann 11 Mär 2022 14:35 #34

  • wbloos
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Beiträge: 33
  • Dank erhalten: 26

Schirmung habe ich drei verschiedene Varianten durchprobiert:

Ok, fehlt dann nur die vierte noch vorhandene Möglichkeit: 
mit Masse an beiden Seiten verbunden , also an den Kamerasteckern und an der Fernbedienung.

Gruß
Werner


 

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Modifizierte Kabelfernbedienung für Sony RX100-Stereogespann 11 Mär 2022 14:59 #35

  • cosima
  • cosimas Avatar
  • Offline
  • Senior Boarder
  • Senior Boarder
  • COrrect Stereo IMAges
  • Beiträge: 53
  • Dank erhalten: 49
Im Prinzip richtig ;-) Ich muß dazu auch sagen, daß ich nicht der große Praktiker bin und ich mich in meinem Berufsleben immer nur mit theoretischen Aspekten der Elektrotechnik beschäftigt habe. Natürlich ist beidseitig GND verbunden und da macht der beidseitige Anschluß der Schirmung eigentlich keinen Sinn ...
Gruß Gerhard

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Letzte Änderung: von cosima.

Modifizierte Kabelfernbedienung für Sony RX100-Stereogespann 11 Mär 2022 15:25 #36

  • wbloos
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Beiträge: 33
  • Dank erhalten: 26
Sinn oder nicht? Letzlich gehts darum obs funktioniert. Hatte schon mal so ne seltsame Situation (hat jetzt nicht direkt was mit der Fernbedienung zu tun, aber mit Abschirmung):

Musste für ein Museum einen Mediaplayer installieren der über 4 Taster eines von 4 Videos startet. Ein  ensprechenden Player hatte ich gefunden der über GPIO Pins am Player sogar 8 Videos starten konnte. Die Auswahlbox mit den 4 Tasten  sollte etwas entfernt vom Player/TV aufgestellt werden so dass da ein 9-poliges ungeschirmtrs Kabel mit einer Länge von 4m zum Einsatz kam, die Taster waren wandalismussichere Metalltaster, die Auswahlbox ein Alu Vierkantrohr. Erster Anschluss: es funktionierte, allerdins nicht zuverlässig: drückte man die Taste 2 sollte Video 2 laufen, alle anderen Tasen entsprechend Video 1 bei Taste1 e.t.c - Fakt war aber dass zwischendurch ein anderes Video lief als die Tastenauwahl es vergab.. ok, Kabel gegen ein abgeschirmtes Netzwerkkabel mit verdrillten Adern getauscht, Abschirmung nicht angeschlossen: Problem blieb, dann Abschirmung an der Auswahlbox angeschlossen, Problem blieb immer noch, erst nachdem die Abschirmung auch am Player an Masse angeschlossen war funktionierte alles problemlos, eigentlich unlogisch, war aber so.

Gruß
Werner


 

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Modifizierte Kabelfernbedienung für Sony RX100-Stereogespann 13 Mär 2022 00:26 #37

  • cosima
  • cosimas Avatar
  • Offline
  • Senior Boarder
  • Senior Boarder
  • COrrect Stereo IMAges
  • Beiträge: 53
  • Dank erhalten: 49
Hallo Werner,
dieser Link von Dir ist doch sehr aufschlußreich und klärt doch eigentlich alle Details: github.com/Aeronavics/ValleyForge/wiki/R...i-Interface-Research

Das Ein- und Ausschalten des Videorecordings (auch Zoomen) verursacht einen mehrfachen Austausch von Telegrammen zwischen Kamera und Fernbedienung. Es wird auch beschrieben, was passiert, wenn die Kamera keine Antwort auf ihre Rückmeldungen mehr bekommt: Die Kamera versucht dann noch genau 5 mal, eine Antwort zu senden.

Da die Videos der beiden Kameras (zumindest bei mir) einen zufälligen Versatz von Frames besitzen, vemute ich, dass die Antworten der beiden Kameras auch diesen zufälligen Versatz besitzen. Das Acknowledge der Fernbedienung auf diese Antwort passt dann nicht mehr zu der nur hörenden Kamera und damit ist für diese Kamera dann die Kommunikation beendet.

Es macht aber trotzdem Sinn, die Sache weiter zu verfolgen (z.B. mit der 2-Platinen-Lösung), da nach dem Ausgleich der Frames der Versatz (beim Video) unterhalb 1ms liegt (Messungen im Bereich 0.0ms bis 0.6ms - das ist zwar nicht perfekt, aber nicht völlig unbrauchbar!).
Gruß Gerhard




 

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Letzte Änderung: von cosima.

Modifizierte Kabelfernbedienung für Sony RX100-Stereogespann 13 Mär 2022 20:18 #38

  • wbloos
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Beiträge: 33
  • Dank erhalten: 26

Da die Videos der beiden Kameras (zumindest bei mir) einen zufälligen Versatz von Frames besitzen, vemute ich, dass die Antworten der beiden Kameras auch diesen zufälligen Versatz besitzen.


Der Frameversatz liegt an der mp4 Kodierung, und kann bis zu 10 Frames betragen, hat aber nichts mit einem Versatz der Kommunikation zu tun. Seltsamerweise gibt es den Versatz bei Kameragespannen mit Mpeg2 NICHT, auch wenn man bei Verwendung von Kasetten und Magnetaufzeichnung eher von einem Versatz ausgehen würde. Warum allerdings dieser Frameversatz auftritt, kann ich nicht logisch erklären, daher emofehle ich bei solchen Grspannen mit einem Knackfrosch (Klicker für Hundetraining, gibts im Zoofachhandel) zu arbeiten, um den Frameversatz leichter korrigieren zu können.

Gruß
Werner

 
Folgende Benutzer bedankten sich: 3Dimages, Wolfgang

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Modifizierte Kabelfernbedienung für Sony RX100-Stereogespann 14 Mär 2022 19:36 #39

  • cosima
  • cosimas Avatar
  • Offline
  • Senior Boarder
  • Senior Boarder
  • COrrect Stereo IMAges
  • Beiträge: 53
  • Dank erhalten: 49
Hallo Werner,
die Tatsache, dass es einen zufälligen Frameversatz gibt, weist zumindest darauf hin, dass es bei der Videoaufnahme in der Kamera offensichtlich Prozesse gibt, die zuerst abgewartet werden müssen, bevor die eigentliche Aufnahme beginnen kann. Für die uns interessierende Video-Synchronisation ist das nicht weiter relevant (denn da ist nur die Phase des Bildtaktes wichtig), aber für die Kommunikation mit der Fernbedienung kann das durchaus eine Rolle spielen. (Ich schreibe bewußt kann, denn wir kennen die Details der Firmware ja nicht.)

Wenn Du in github.com/Aeronavics/ValleyForge/wiki/R...i-Interface-Research genauer in die Kommandos hineinschaust, siehst Du z.B., dass dort nach dem Befehl, die Videoaufnahme zu starten, die erste Antwort der Kamera nach 43ms kommt. Es wäre doch gut möglich, dass damit genau der Start der Aufnahme von der Kamera quittiert wird. Natürlich ist das nur eine Hypothese, aber in einem Elektroniklabor könnte man diese These mit Hilfe eines Speicheroszilloskops leicht verfizieren bzw. falsifizieren.
Gruß, Gerhard

PS: Der Empfehlung mit dem Knackfrosch kann ich mich nur anschließen! Shift T im COSIMA Videopreviewer gleicht den Frameversatz automatisch aus, das geht mit so einer akustischen Klappe sehr viel sicherer.
Folgende Benutzer bedankten sich: Wolfgang

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.570 Sekunden
Powered by Kunena Forum